CVE-2026-14265- Deserialization of Untrusted Data in AWS Advanced JDBC Wrapper RemoteQueryCachePlugin
Advanced Jdbc ยท 2026-10-19
Actions
Technical Details
| Affected Versions | >=3.3.0, <=4.0.0 |
|---|---|
| Regions | all |
| CVE IDs | CVE-2026-14265 |
| Migration Required | Yes |
| Cost Impact | Neutral |
| IaC Impact | High |
What This Means
For DevOps Teams
Update the AWS Advanced JDBC Wrapper to version 4.0.1 and disable the RemoteQueryCachePlugin if an immediate upgrade is not feasible, to address the deserialization vulnerability (CVE-2026-14265) and prevent potential security breaches.
For Platform Teams
Deploy the latest AWS Advanced JDBC Wrapper version 4.0.1 across all relevant environments to resolve the deserialization issue in the RemoteQueryCachePlugin, enhancing overall platform security and reliability.
For Executives
Implement the upgrade to AWS Advanced JDBC Wrapper version 4.0.1 to mitigate the risk of arbitrary code execution due to deserialization of untrusted data, ensuring application security and maintaining customer trust.