CVE-2026-85228 - Integer overflow in tensor buffer validation in Deep Java Library
AWS ยท 2026-10-25
Actions
Technical Details
| Affected Versions | >=0.13.0, <=0.36.0 |
|---|---|
| Regions | all |
| CVE IDs | CVE-2026-85228 |
| Migration Required | Yes |
| Cost Impact | Neutral |
| IaC Impact | High |
What This Means
For DevOps Teams
Update DJL to version 0.37.0 or later to address the integer overflow vulnerability (CVE-2026-85228) and prevent potential security incidents.
For Platform Teams
Deploy the latest DJL version 0.37.0 to ensure the platform is secure from the integer overflow vulnerability affecting tensor buffer validation.
For Executives
Implement the recommended upgrade to DJL version 0.37.0 to mitigate the risk of data breaches and service disruptions caused by the integer overflow vulnerability.